summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-09-04 04:43:26 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-09-04 04:43:26 +0000
commitdb1571b1b466d20f6a17c85ab062ad37eddb588c (patch)
tree2821e456507d0411170a667cc21a3e76153c5784 /configure.in
parent5c3523de765b41584cfcebb8aebbaa6ac9433c35 (diff)
eban
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@926 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index be54aa5091..285aa2199d 100644
--- a/configure.in
+++ b/configure.in
@@ -849,17 +849,18 @@ case "$target_os" in
esac
;;
cygwin*|mingw*)
+ RUBY_SO_NAME='$(RUBY_INSTALL_NAME)'.$target_os
if test x"$enable_shared" = xyes; then
- LIBRUBY_SO='$(RUBY_INSTALL_NAME).'$target_os.dll
+ LIBRUBY_SO='$(RUBY_SO_NAME)'.dll
LIBRUBY_DLDFLAGS='--dllname=$@ --output-lib=$(LIBRUBY) --add-stdcall-alias --def=$(RUBYDEF)'
else
LIBRUBY_SO=dummy
- LIBRUBY_DLDFLAGS='--output-exp=$(RUBY_INSTALL_NAME).exp --dllname=$(RUBY_INSTALL_NAME)$(EXEEXT) --output-lib=$(LIBRUBY) --add-stdcall-alias --def=$(RUBYDEF)'
+ LIBRUBY_DLDFLAGS='--output-exp=$(RUBY_SO_NAME).exp --dllname=$(RUBY_SO_NAME)$(EXEEXT) --output-lib=$(LIBRUBY) --add-stdcall-alias --def=$(RUBYDEF)'
fi
LIBRUBY_ALIASES=''
LIBRUBY_A='lib$(RUBY_INSTALL_NAME)s.a'
- LIBRUBY='lib$(RUBY_INSTALL_NAME).a'
- LIBRUBYARG='-L. -l$(RUBY_INSTALL_NAME)'
+ LIBRUBY='lib$(RUBY_SO_NAME).a'
+ LIBRUBYARG='-L. -l$(RUBY_SO_NAME)'
FIRSTMAKEFILE=GNUmakefile:cygwin/GNUmakefile.in
SOLIBS='$(LIBS)'
case "$target_os" in