summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-09-15 12:57:21 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-09-15 12:57:21 +0000
commitce296ec7fc8fc02b1b95bac13b763100c66eb909 (patch)
treefa293e5b3b8891fa329dbff87baf7d2edda6b47a /configure.in
parentaa904b2050026a0fa6bc7d3e1869dc471c1b0749 (diff)
* configure.in (OUTFLAG, CPPOUTFILE): moved from lib/mkmf.rb.
check whether ${CPP} accepts the -o option. * win32/Makefile.sub (OUTFLAG, CPPOUTFILE): ditto. * bcc32/Makefile.sub (OUTFLAG, CPPOUTFILE): ditto. * djgpp/config.sed (OUTFLAG, CPPOUTFILE): ditto. * lib/mkmf.rb (OUTFLAG, CPPOUTFILE): use CONFIG. make easy to understand log. * mkconfig.rb (val): should not strip. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@2867 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d299c633bb..4ed1081720 100644
--- a/configure.in
+++ b/configure.in
@@ -98,6 +98,16 @@ fi
AC_PROG_CC
AC_PROG_GCC_TRADITIONAL
+echo 'foo(){}' > conftest.c
+if ${CPP} -o conftest.i conftest.c >/dev/null 2>&1; then
+ CPPOUTFILE='-o conftest.i'
+else
+ CPPOUTFILE='> conftest.i'
+fi
+AC_SUBST(CPPOUTFILE)
+OUTFLAG='-o '
+AC_SUBST(OUTFLAG)
+
AC_PROG_YACC
AC_CHECK_TOOL(RANLIB, ranlib, :)
AC_CHECK_TOOL(AR, ar)