summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-01-19 03:01:12 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-01-19 03:01:12 +0000
commite8e1a374f0a876a738027f5aaabba85b21a6538a (patch)
treeaa4ab4c5a9224ec83f3383af14dbb611e6aecbfd /configure.in
parentb55129c3c544e37cf8d21e9f5c4ffdcb9b71eb73 (diff)
merge revision(s) 49306: [Backport #10750]
* configure.in: get rid of pattern substitution, which is not supported by ash, and ash on NetBSD parses whole source first and fails to start. [ruby-dev:48823] [Bug #10750] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@49329 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 599a22ee2e..b3deed24fe 100644
--- a/configure.in
+++ b/configure.in
@@ -3018,7 +3018,7 @@ if test "$with_dln_a_out" != yes; then
"-undefined dynamic_lookup" \
"-multiply_defined suppress" \
; do
- test "x${linker_flag}" = x || flag="${linker_flag}${flag// /,}"
+ test "x${linker_flag}" = x || flag="${linker_flag}`echo ${flag} | tr ' ' ,`"
RUBY_TRY_LDFLAGS([$flag], [], [flag=])
if test "x$flag" != x; then
RUBY_APPEND_OPTIONS(DLDFLAGS, [$flag])