summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-01-17 14:42:30 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-01-17 14:42:30 +0000
commit748372be9715f89eabadf2840604ea24f3d0e026 (patch)
tree80b8f204a23fa33dccc5e26aae6e07e87377610e /configure.in
parente1aabbd397d3bb0a202dc9df156cb00a6a30b330 (diff)
configure.in: no pattern substitution
* configure.in: get rid of pattern substitution, which is not supported by ash, and ash on NetBSD parses whole source first and fails to start. [ruby-dev:48823] [Bug #10750] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@49306 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 599a22ee2e..b3deed24fe 100644
--- a/configure.in
+++ b/configure.in
@@ -3018,7 +3018,7 @@ if test "$with_dln_a_out" != yes; then
"-undefined dynamic_lookup" \
"-multiply_defined suppress" \
; do
- test "x${linker_flag}" = x || flag="${linker_flag}${flag// /,}"
+ test "x${linker_flag}" = x || flag="${linker_flag}`echo ${flag} | tr ' ' ,`"
RUBY_TRY_LDFLAGS([$flag], [], [flag=])
if test "x$flag" != x; then
RUBY_APPEND_OPTIONS(DLDFLAGS, [$flag])