summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-12-20 23:35:33 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-12-20 23:35:33 +0000
commit65cc2e8374d6caaefcc2cf00a3248e1060ac3bf2 (patch)
tree198d812f937cae879a1ec958df0c00611fe6e217 /configure.in
parentfa9f7c25574dff38327a3ba08cd74c76eb303c59 (diff)
configure.in: fix jemalloc option
* configure.in (jemalloc): fix option argument, should use `$withval` but not `yes` always. [ruby-core:66994] [Bug #10625] * configure.in (jemalloc): defer adding the liner option to get rid of linking contest against jemalloc, so that it works without runtime dynamic load path. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@48907 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e132076d65..9bcd684752 100644
--- a/configure.in
+++ b/configure.in
@@ -1204,7 +1204,7 @@ AS_IF([test "x$with_gmp" != xno],
AC_ARG_WITH([jemalloc],
[AS_HELP_STRING([--with-jemalloc],[use jemalloc allocator])],
- [with_jemalloc=yes], [with_jemalloc=no])
+ [with_jemalloc=$withval], [with_jemalloc=no])
AS_IF([test "x$with_jemalloc" = xyes],[
AC_CHECK_LIB([jemalloc], [malloc_conf], [], [with_jemalloc=no])
AC_CHECK_HEADER(jemalloc/jemalloc.h, [
@@ -1225,7 +1225,6 @@ AS_IF([test "x$with_jemalloc" = xyes],[
AS_IF([test "x$rb_cv_jemalloc_demangle" = xyes], [
AC_DEFINE(JEMALLOC_MANGLE)
with_jemalloc=yes
- LIBS="-ljemalloc $LIBS"
])
AS_IF([test "x$with_jemalloc" = xyes],
[
@@ -3769,6 +3768,9 @@ AS_CASE(["$target_os"],
AS_CASE(["$with_gmp: $SOLIBS "], [no:* | *' -lgmp '*|*' $(LIBS) '*], [],
[SOLIBS="-lgmp $SOLIBS"])
+AS_CASE(["$with_jemalloc: $LIBS "], [no:* | *' -ljemalloc '*], [],
+ [LIBS="-ljemalloc $LIBS"])
+
MINIOBJS="$MINIDLNOBJ"
AS_CASE(["$THREAD_MODEL"],