summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-09-07 05:22:13 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-09-07 05:22:13 +0000
commita209dd2f60e641d1dc78997dfc47852685e22cc3 (patch)
tree07fb57f9502b65a4e6083c728a19361abb28b5a3 /configure.in
parent1c19abfab967132315eceae11a8f9e87362a527b (diff)
* configure.in (group_member): check if presents.
* configure.in (XCFLAGS): add _GNU_SOURCE on linux. * file.c (group_member): use system routine if available. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8_5@13367 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5988961855..4b9e25e668 100644
--- a/configure.in
+++ b/configure.in
@@ -489,7 +489,7 @@ AC_CHECK_FUNCS(fmod killpg wait4 waitpid syscall chroot fsync getcwd eaccess\
setproctitle setrgid setegid setregid setresgid issetugid pause\
lchown lchmod getpgrp setpgrp getpgid setpgid initgroups\
getgroups setgroups getpriority getrlimit setrlimit sysconf\
- dlopen sigprocmask\
+ group_member dlopen sigprocmask\
sigaction _setjmp setsid telldir seekdir fchmod mktime timegm\
cosh sinh tanh setuid setgid setenv unsetenv)
AC_ARG_ENABLE(setreuid,
@@ -1359,6 +1359,9 @@ fi
AC_SUBST(RDOCTARGET)
case "$target_os" in
+ linux*)
+ XCFLAGS="$XCFLAGS -D_GNU_SOURCE=1"
+ ;;
netbsd*)
CFLAGS="$CFLAGS -pipe"
;;