summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-05-02 07:50:36 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-05-02 07:50:36 +0000
commit20ed1f8d1a7ff59b884ff5d878b4fc99d0723f93 (patch)
tree913bb5562143a9047dcf731f325c6a80614e5552 /configure.in
parentb5a8ba178ffa5ba106a893a958db05e1dd4abd82 (diff)
* error.c: use HAVE_DECL_SYS_NERR instead of platform names.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@2423 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d97df02523..0785fef1bb 100644
--- a/configure.in
+++ b/configure.in
@@ -109,6 +109,13 @@ cygwin*|mingw*)
;;
esac
+# by TOYODA Eizi <toyoda@npd.kishou.go.jp>
+case "$target_os" in
+hiuxmpp*)
+ AC_DEFINE(__HIUX_MPP__)
+ ;;
+esac
+
AC_PROG_LN_S
AC_PROG_MAKE_SET
@@ -179,8 +186,10 @@ NORETURN(void exit(int x));],
done])
AC_DEFINE_UNQUOTED([NORETURN(x)], $rb_cv_noreturn)
+dnl Check whether we need to define sys_nerr locally
+AC_CHECK_DECLS([sys_nerr])
-dnl wheather link libc_r or not
+dnl whether link libc_r or not
AC_ARG_WITH(libc_r,
[ --with-libc_r link libc_r if possible (FreeBSD only)], [
case $withval in
@@ -712,6 +721,7 @@ if test "$with_dln_a_out" != yes; then
cygwin*|mingw*) : ${LDSHARED="${CC} -shared -s"}
LDFLAGS='-Wl,--stack,0x02000000'
rb_cv_dlopen=yes ;;
+ hiuxmpp) LDSHARED='ld -r' ;;
*) LDSHARED='ld' ;;
esac
AC_MSG_RESULT($rb_cv_dlopen)