summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-10-29 02:51:00 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-10-29 02:51:00 +0000
commit19873d5cf91ffbef052a52b3c55fb170a72fd4b5 (patch)
treed1126a60c43d4bccc124a4479bb6a2826b8f5948 /configure.in
parentb3b3c1746169183d9c97a90f9d0df2e8d7f6d3c0 (diff)
* configure.in (dln-a-out): cannot make shared library nor work with
ELF. [ruby-core:19571] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_1@20016 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index dfa495bee6..83e76711df 100644
--- a/configure.in
+++ b/configure.in
@@ -1253,7 +1253,13 @@ dnl wheather use dln_a_out or not
AC_ARG_WITH(dln-a-out,
[ --with-dln-a-out use dln_a_out if possible], [
case $withval in
- yes) with_dln_a_out=yes;;
+ dnl (
+ yes)
+ if test "$enable_shared" = yes; then
+ AC_MSG_ERROR(dln_a_out can not make shared library)
+ fi
+ with_dln_a_out=yes;;
+ dnl (
*) with_dln_a_out=no;;
esac], [with_dln_a_out=no])
@@ -1271,6 +1277,9 @@ rb_cv_binary_elf=no)])
if test "$rb_cv_binary_elf" = yes; then
AC_DEFINE(USE_ELF)
+ if test "$with_dln_a_out" = yes; then
+ AC_MSG_ERROR(dln_a_out does not work with ELF)
+ fi
fi
case "$target_os" in