summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-06-01 12:58:56 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-06-01 12:58:56 +0000
commitfd681fe0e5240ae112b15ff437d3259f202b9705 (patch)
tree3c702e558fd624f097011e635fb851425d7623c8 /configure.in
parentdc13952417e5c918de9bd51f504db7a289ddabed (diff)
* configure.in: should not use def file, use ld with
--export-all-symbols option on Cygwin/MinGW. * defines.h: ditto. * cygwin/GNUmakefile.in: ditto. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@3894 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index e115561b8a..7bf4e39a86 100644
--- a/configure.in
+++ b/configure.in
@@ -833,7 +833,7 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes;;
cygwin*|mingw*) : ${LDSHARED="${CC} -shared -s"}
XLDFLAGS='-Wl,--stack,0x02000000'
- DLDFLAGS="${DLDFLAGS} -Wl,--enable-auto-import "'$(DEFFILE)'
+ DLDFLAGS="${DLDFLAGS} -Wl,--enable-auto-import,--export-all"
rb_cv_dlopen=yes ;;
hiuxmpp) LDSHARED='ld -r' ;;
atheos*) LDSHARED="$CC -shared"
@@ -1166,7 +1166,6 @@ case "$target_os" in
esac
;;
cygwin*|mingw*)
- EXPORT_PREFIX=' '
case "$target_os" in
cygwin*)
RUBY_SO_NAME=$target_os-'$(RUBY_INSTALL_NAME)'${MAJOR}${MINOR}
@@ -1180,14 +1179,13 @@ case "$target_os" in
COMMON_HEADERS="windows.h winsock.h"
;;
esac
- XCFLAGS="$XCFLAGS -DRUBY_EXPORT"
+ XCFLAGS="$XCFLAGS"
+ LIBRUBY_DLDFLAGS="${DLDFLAGS}"' -Wl,--out-implib=$(LIBRUBY)'
if test x"$enable_shared" = xyes; then
LIBRUBY_SO='$(RUBY_SO_NAME)'.dll
- LIBRUBY_DLDFLAGS='-Wl,--out-implib=$(LIBRUBY) $(RUBYDEF)'
LIBRUBY='lib$(LIBRUBY_SO).a'
else
LIBRUBY_SO=dummy
- LIBRUBY_DLDFLAGS=''
LIBRUBY='lib$(RUBY_SO_NAME).a'
LIBRUBYARG='-l$(RUBY_SO_NAME)'
fi