summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-12-02 14:09:44 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-12-02 14:09:44 +0000
commit14e831dd21a7b50e385bdceaa1a3b70012f3d790 (patch)
tree85f965d8dc7b5b86d1b29518be02016fdfb68d98 /configure.in
parent2ef1e686fa47bcf60890255f9d6c8d5c004c80f9 (diff)
* configure.in: use GCC, not without_gcc. remove without_gcc.
* ext/curses/extconf.rb: check for curses.h. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_6@1872 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 8 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 4dc1a979df..c3cf25d7bb 100644
--- a/configure.in
+++ b/configure.in
@@ -12,14 +12,12 @@ dnl checks for alternative programs
AC_ARG_WITH(gcc, [--without-gcc never use gcc], [
case $withval in
no) : ${CC=cc}
- without_gcc=yes;;
+ ;;
yes) : ${CC=gcc}
- without_gcc=no;;
+ ;;
*) CC=$withval
- without_gcc=$withval;;
- esac], [
- : ${CC=gcc}
- without_gcc=no])
+ ;;
+ esac])
dnl If the user switches compilers, we can't believe the cache
if test ! -z "$ac_cv_prog_CC" -a ! -z "$CC" -a "$CC" != "$ac_cv_prog_CC"
then
@@ -242,10 +240,10 @@ linux*) LIBS="-lm $LIBS"
CFLAGS="-mieee $CFLAGS" ;;
esac ;;
osf*) LIBS="-lm $LIBS"
- case "$target_cpu"::"$without_gcc" in
- alpha*::no)
- CFLAGS="-mieee $CFLAGS" ;;
+ case "$target_cpu"::"$GCC" in
alpha*::yes)
+ CFLAGS="-mieee $CFLAGS" ;;
+ alpha*::no|alpha*::)
CFLAGS="-ieee $CFLAGS" ;;
esac ;;
*) LIBS="-lm $LIBS";;
@@ -892,7 +890,7 @@ case "$target_os" in
CFLAGS="$CFLAGS -DOS2"
;;
osf*)
- if test "$without_gcc" = "yes" ; then
+ if test "$GCC" != "yes" ; then
# compile something small: taint.c is fine for this.
# the main point is the '-v' flag of 'cc'.
case "`cc -v -I. -c main.c -o /tmp/main.o 2>&1`" in