summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornagachika <nagachika@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-04-22 15:10:54 +0000
committernagachika <nagachika@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-04-22 15:10:54 +0000
commitfdd8cf9762ec940542f5eb3ae19ebdf81afacc0d (patch)
tree7b8915413c7bac1eb20ccd2401ddea93fde9c398 /configure.in
parentcce82740b5b7f814196ddd2ad78242d02ce2e11c (diff)
merge revision(s) 54657,54660: [Backport #12303]
* configure.in: check if succeeded in creating config.h. * tool/ifchange: ignore failures when TEST_COLORS unmatched. just use the default value if expected name is not contained in it. [ruby-core:75046] [Bug #12303] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@54710 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1d083ea0a3..f20871e729 100644
--- a/configure.in
+++ b/configure.in
@@ -748,7 +748,7 @@ RUBY_WERROR_FLAG([
cp ../confdefs.h . &&
echo '<?xml?><plist><dict><key>CFBundleIdentifier</key><string></string></dict></plist>' > Info.plist &&
:
- } || AC_MSG_ERROR([faild to make temporary directory])
+ } || AC_MSG_ERROR([failed to make temporary directory])
AC_TRY_LINK([], [],
[AC_MSG_RESULT(yes)],
[
@@ -4395,7 +4395,7 @@ guard=INCLUDE_RUBY_CONFIG_H
(
if test "x$CONFIGURE_TTY" = xyes; then color=--color; else color=; fi
exec ${srcdir}/tool/ifchange $color "${config_h}" -
-)
+) || AC_MSG_ERROR([failed to create ${config_h}])
tr -d '\015' < largefile.h > confdefs.h
rm largefile.h