summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornagachika <nagachika@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-03-27 17:59:49 +0000
committernagachika <nagachika@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-03-27 17:59:49 +0000
commite6e4d2e158d0d6076cc89d8d2549108f8f61730e (patch)
tree9784e447011560bd13e810ed68128c8cc4d515c3 /configure.in
parentda9963b5cf0e53e3fe33a2174e75c116a12af5e3 (diff)
merge revision(s) 58084: [Backport #13361]
configure.in: syscall is deprecated on macOS * configure.in: syscall is no longer supported on macOS since 10.12. [ruby-core:80300] [Bug #13361] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@58187 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b5876294f1..0a2e78f0e1 100644
--- a/configure.in
+++ b/configure.in
@@ -1051,6 +1051,12 @@ AS_CASE(["$target_os"],
],
[macosx_10_5=yes], [macosx_10_5=no])
AC_MSG_RESULT($macosx_10_5)
+ AS_IF([test "${target_os@%:@darwin}" -ge 16], [
+ ac_cv_func___syscall=no
+ ac_cv_func_syscall=no
+ ac_cv_header_sys_syscall_h=no
+ ac_cv_header_syscall_h=no
+ ])
if test $macosx_10_5 = yes; then
ac_cv_func_getcontext=no
ac_cv_func_setcontext=no