summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorusa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-01-31 13:58:12 +0000
committerusa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-01-31 13:58:12 +0000
commit766c3744f48e69461db09942bfe02790753ead40 (patch)
tree638bd48e45b43eb3c29cea8f5a86a2aab4ef0a47 /configure.in
parent4cc2435aa77f3e651fb7b9c5270672dfb5364576 (diff)
merge revision(s) 60182: [Backport #14009]
configure.ac: link Foundation framework * configure.ac (XLDFLAGS): link against Foundation framework and let __NSPlaceholderDictionary initialize, to get rid of crash after fork on macOS High Sierra. [ruby-core:83239] [Bug #14009] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@62144 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0dbd5b1613..b5ba86213f 100644
--- a/configure.in
+++ b/configure.in
@@ -3987,8 +3987,8 @@ AS_CASE(["$target_os"],
],
[darwin*], [
RUBY_APPEND_OPTION(CFLAGS, -pipe)
- RUBY_APPEND_OPTION(XLDFLAGS, [-framework CoreFoundation])
- RUBY_APPEND_OPTION(LIBRUBYARG_STATIC, [-framework CoreFoundation])
+ RUBY_APPEND_OPTION(XLDFLAGS, [-framework Foundation])
+ RUBY_APPEND_OPTION(LIBRUBYARG_STATIC, [-framework Foundation])
],
[osf*], [
if test "$GCC" != "yes" ; then