summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-12-25 09:55:10 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-12-25 09:55:10 +0000
commit85f9d86cb8c34fb1534b536d16b2558ba5bd9d99 (patch)
treea0f4a60ccf201fc136272e8bf437d369b0a701dc /configure.in
parent509ba5db33a8866b1978376f8be94cc7d175d190 (diff)
merges r20964 from trunk into ruby_1_9_1.
* configure.in (HAVE_LONG_LONG, HAVE_OFF_T): revised for autoconf 2.62 or later. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_1@21021 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8fd3c33a9f..f20cf35440 100644
--- a/configure.in
+++ b/configure.in
@@ -281,6 +281,8 @@ mingw*)
;;
esac
+AC_CHECK_TYPES([long long, off_t])
+
AC_CHECK_SIZEOF(int, 4)
AC_CHECK_SIZEOF(short, 2)
AC_CHECK_SIZEOF(long, 4)
@@ -292,9 +294,6 @@ AC_CHECK_SIZEOF(float, 4)
AC_CHECK_SIZEOF(double, 8)
AC_CHECK_SIZEOF(time_t, 0)
-[test "${ac_cv_type_long_long}" = yes] && AC_DEFINE(HAVE_LONG_LONG)
-[test "${ac_cv_type_off_t}" = yes] && AC_DEFINE(HAVE_OFF_T)
-
dnl RUBY_REPLACE_TYPE [typename] [default type] [macro type] [included]
AC_DEFUN([RUBY_REPLACE_TYPE], [dnl
AC_CHECK_TYPE([$1],