summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-04-22 09:49:15 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-04-22 09:49:15 +0000
commit81e661b298177105d915a1fe8e1e47ddd0a46122 (patch)
tree454b96781966f55006bc2b8d20cf14b00caa3821 /configure.in
parent08c110d86f6c9e228c1280920f3bc8e6b971b64a (diff)
* configure.in: add -mieee to CFLAGS on Linux/Alpha
to disable "DIVISION BY ZERO" exception. * configure.in: remove -ansi on OSF/1. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_6@1331 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 094098861d..6910091f92 100644
--- a/configure.in
+++ b/configure.in
@@ -236,6 +236,11 @@ freebsd*) LIBS="-lm $LIBS"
fi
fi
;;
+linux*) LIBS="-lm $LIBS"
+ case "$target_cpu" in
+ alpha*)
+ CFLAGS="-mieee $CFLAGS" ;;
+ esac ;;
*) LIBS="-lm $LIBS";;
esac
AC_CHECK_LIB(crypt, crypt)
@@ -872,9 +877,7 @@ case "$target_os" in
CFLAGS="$CFLAGS -DOS2"
;;
osf*)
- if test "$without_gcc" = "no" ; then
- CFLAGS="$CFLAGS -ansi"
- else
+ if test "$without_gcc" = "yes" ; then
# compile something small: taint.c is fine for this.
# the main point is the '-v' flag of 'cc'.
case "`cc -v -I. -c main.c -o /tmp/main.o 2>&1`" in