summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-05-02 19:08:07 +0000
committerknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-05-02 19:08:07 +0000
commit6d65fca534c212a215494a928a21f0c89cd4ea87 (patch)
tree6cd926be4b12ae6b3bf6b8d75399d5a09fc7b349 /configure.in
parentb77916ffd8c8cb729e9d60d076efe0f22512e669 (diff)
* configure.in: get --enable-shared to work on MacOS X.
* Makefile.in: make $(LIBRUBY_SO) depend on miniruby properly. Now `make -jN' should work without a problem. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_6@1361 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2e043a497e..20a0a19199 100644
--- a/configure.in
+++ b/configure.in
@@ -501,7 +501,7 @@ if test "$with_dln_a_out" != yes; then
nextstep*) ;;
openstep*) ;;
rhapsody*) ;;
- darwin*) ;;
+ darwin*) CCDLFLAGS=-fno-common;;
human*) ;;
bsdi*) ;;
beos*) ;;
@@ -863,6 +863,12 @@ if test "$enable_shared" = 'yes'; then
;;
esac
;;
+ darwin*)
+ LIBRUBY_SO='lib$(RUBY_INSTALL_NAME).$(MAJOR).$(MINOR).$(TEENY).dylib'
+ LIBRUBY_LDSHARED='cc -dynamiclib -undefined suppress'
+ LIBRUBY_DLDFLAGS='-install_name lib$(RUBY_INSTALL_NAME).dylib -current_version $(MAJOR).$(MINOR).$(TEENY) -compatibility_version $(MAJOR).$(MINOR)'
+ LIBRUBY_ALIASES='lib$(RUBY_INSTALL_NAME).$(MAJOR).$(MINOR).dylib lib$(RUBY_INSTALL_NAME).dylib'
+ ;;
*)
;;
esac