summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-02-05 12:01:25 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-02-05 12:01:25 +0000
commit95b22614631e9ec157e1436d860883a8938cc21a (patch)
treee61623d05537c8cbe222e5ec7c7dca8cbdefd973 /configure.in
parent26ea147c052fbe2b4642183adb8705d1de9667fc (diff)
merged revision 21628:
* configure.in (darwin): get rid of strange settings issue of apple gcc port, which searches /usr/local/include always but /usr/local/lib not. * ext/readline/readline.c (Init_readline): suppress warnings with libedit. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8@22079 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 469a52cbd7..3ecdfacc3d 100644
--- a/configure.in
+++ b/configure.in
@@ -1247,6 +1247,14 @@ if test "$with_dln_a_out" != yes; then
darwin*) : ${LDSHARED='cc -dynamic -bundle -undefined suppress -flat_namespace'}
: ${LDFLAGS=""}
: ${LIBPATHENV=DYLD_LIBRARY_PATH}
+ # /usr/local/include is always searched for
+ # some reason, but /usr/local/lib is not.
+ hdr=`find /usr/local/include -name \*.h -type f | sed 's:^/usr/local/include/::;q'`
+ if test -n "$hdr" && $CC -E -include "$hdr" -xc /dev/null | fgrep -q "$hdr"; then
+ $CC -print-search-dirs | grep -q '^libraries:.*:/usr/local/lib/*' ||
+ echo " $LDFLAGS " | grep -q ' -L */usr/local/lib/* ' ||
+ LDFLAGS="${LDFLAGS:+$LDFLAGS }-L/usr/local/lib"
+ fi
rb_cv_dlopen=yes ;;
aix*) if test "$GCC" = yes; then
: ${LDSHARED='$(CC) -shared'}