summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTakashi Kokubun <takashikkbn@gmail.com>2022-09-05 01:17:12 -0700
committerTakashi Kokubun <takashikkbn@gmail.com>2022-09-05 01:25:00 -0700
commitcb26917d1cfa6a02d5e1e951ebec4e9c886902cf (patch)
tree3e65bf858238df3071745b6f438c2bc02ff52cea /configure.ac
parent06eb9af8c0d6f415f96a81d4af5c7f8fe3c14ebc (diff)
Drop Solaris support for MJIT
I tried to debug: http://rubyci.s3.amazonaws.com/solaris10-gcc/ruby-master/log/20220905T070005Z.fail.html.gz but I don't have sudo privilege to install dependencies such as xz on that machine. Thus I can't extract a prebuilt libclang binary. Anyway, if we find out ABI is different from x86_64 / aarch64, we'd like to have sparc CI associated to GitHub to run `make mjit-bindgen`, but we can't. Supporting this could be too hard, so I'm leaving it for now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a9fc9932ae..5b0aa218d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3744,7 +3744,7 @@ AC_ARG_ENABLE(jit-support,
AS_HELP_STRING([--disable-jit-support], [disable JIT features]),
[MJIT_SUPPORT=$enableval],
[AS_CASE(["$target_os"],
- [wasi | mingw*], [MJIT_SUPPORT=no],
+ [wasi | mingw* | solaris*], [MJIT_SUPPORT=no],
[MJIT_SUPPORT=yes]
)])