summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYuta Saito <kateinoigakukun@gmail.com>2022-07-30 17:25:12 +0900
committerYuta Saito <kateinoigakukun@gmail.com>2022-08-04 16:29:22 +0900
commit6d8b9a9d619821b722273d93cdc4645ae2e23ede (patch)
treef33b00dff19d81557f5432b32c2dab31b4f397db /configure.ac
parente5a3f232563139fdf15660d54aeaec112ffc2349 (diff)
Resolve abi symbol references from miniruby to avoid circular deps
Adding `ruby` to `PREP` causes the following circular dependencies because `PREP` is used as a prerequisite by some targets required to build `ruby` target itself. ``` make: Circular .rbconfig.time <- ruby dependency dropped. make: Circular builtin_binary.inc <- ruby dependency dropped. make: Circular ext/extinit.c <- ruby dependency dropped. make: Circular ruby <- ruby dependency dropped. ``` Adding a new Make variable like `EXTPREP` only for exts may be also reasonable, but it would introduce another complexity into our build system. `-bundle_loader` doesn't care that link-time and run-time loader executables are different as long as bound symbols are provided, so it's ok to resolve from miniruby to simplify our build.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/6193
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1808a643f3..c68b7632e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3015,7 +3015,6 @@ STATIC=
# When building ext bundles, a mach-o bundle needs to know its loader
# program to bind symbols from the ruby executable
EXTDLDFLAGS="-bundle_loader '\$(BUILTRUBY)'"
- PREP="$PREP"' $(PROGRAM)'
])
rb_cv_dlopen=yes],
[aix*], [ : ${LDSHARED='$(CC)'}
@@ -3340,7 +3339,7 @@ AS_IF([test x"$cross_compiling" = xyes], [
AC_SUBST(XRUBY_LIBDIR)
AC_SUBST(XRUBY_RUBYLIBDIR)
AC_SUBST(XRUBY_RUBYHDRDIR)
- PREP="$PREP "'$(arch)-fake.rb'
+ PREP='$(arch)-fake.rb'
RUNRUBY_COMMAND='$(MINIRUBY) -I`cd $(srcdir)/lib; pwd`'
RUNRUBY='$(RUNRUBY_COMMAND)'
XRUBY='$(MINIRUBY)'
@@ -3350,7 +3349,7 @@ AS_IF([test x"$cross_compiling" = xyes], [
], [
MINIRUBY='./miniruby$(EXEEXT) -I$(srcdir)/lib -I.'
MINIRUBY="$MINIRUBY"' -I$(EXTOUT)/common'
- PREP="$PREP "'miniruby$(EXEEXT)'
+ PREP='miniruby$(EXEEXT)'
RUNRUBY_COMMAND='$(MINIRUBY) $(tooldir)/runruby.rb --extout=$(EXTOUT) $(RUNRUBYOPT)'
RUNRUBY='$(RUNRUBY_COMMAND) --'
XRUBY='$(RUNRUBY)'