summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Hawthorn <john@hawthorn.email>2022-07-29 15:07:06 -0700
committerJohn Hawthorn <john@hawthorn.email>2022-07-29 16:32:14 -0700
commit0e85586ecc983ebb4541cd046949428d1ef5d635 (patch)
tree20881720fd3c802c63b28f9eb4dd0b5a8c7b5da4 /configure.ac
parentfbd24793cb7be2429edafcf11d7dd4a7d11f5c95 (diff)
Add --enable-yjit=dev_nodebug configure option
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/6105
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 46ea038865..864a9a4e8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3736,7 +3736,7 @@ CARGO=
CARGO_BUILD_ARGS=
YJIT_LIBS=
AS_CASE(["${YJIT_SUPPORT}"],
-[yes|dev|stats], [
+[yes|dev|stats|dev_nodebug], [
AS_IF([test x"$enable_jit_support" = "xno"],
AC_MSG_ERROR([--disable-jit-support but --enable-yjit. YJIT requires JIT support])
)
@@ -3754,9 +3754,13 @@ AS_CASE(["${YJIT_SUPPORT}"],
CARGO_BUILD_ARGS='--features stats,disasm,asm_comments'
AC_DEFINE(RUBY_DEBUG, 1)
],
+ [dev_nodebug], [
+ rb_rust_target_subdir=dev_nodebug
+ CARGO_BUILD_ARGS='--profile dev_nodebug --features stats,disasm,asm_comments'
+ ],
[stats], [
rb_rust_target_subdir=stats
- CARGO_BUILD_ARGS='--profile stats --features stats,disasm,asm_comments'
+ CARGO_BUILD_ARGS='--profile stats --features stats'
])
AS_IF([test -n "${CARGO_BUILD_ARGS}"], [