summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-08-16 13:45:30 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-08-16 13:45:30 +0900
commit5087a6a9244066f966b1d213142258f01a4bbd13 (patch)
tree26dcb12be9136bf54092f312d2f07a92cf0583dc /configure.ac
parent4cc44bd8194791c624f3452dbf3374661501d97e (diff)
Fix COROUTINE_SRC on emscripten
Select the C source if exists, otherwise the assembler source, instead of selecting by the coroutine type.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4745
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 755e556ac1..2449887301 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2573,14 +2573,9 @@ AS_CASE([$coroutine_type], [yes|''], [
COROUTINE_H=coroutine/$coroutine_type/Context.h
AS_IF([test ! -f "$srcdir/$COROUTINE_H"],
[AC_MSG_ERROR('$coroutine_type' is not supported as coroutine)])
-AS_CASE([$coroutine_type],
- [ucontext|pthread], [
- COROUTINE_SRC=coroutine/$coroutine_type/Context.c
- ],
- [
- COROUTINE_SRC=coroutine/$coroutine_type/Context.'$(ASMEXT)'
- ]
-)
+COROUTINE_SRC=coroutine/$coroutine_type/Context.c
+AS_IF([test ! -f "$srcdir/$COROUTINE_SRC"],
+ [COROUTINE_SRC=coroutine/$coroutine_type/Context.'$(ASMEXT)'])
AC_DEFINE_UNQUOTED(COROUTINE_H, ["$COROUTINE_H"])
AC_SUBST(X_COROUTINE_H, [$COROUTINE_H])
AC_SUBST(X_COROUTINE_SRC, [$COROUTINE_SRC])