summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormame <mame@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-02-15 01:59:15 +0000
committermame <mame@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-02-15 01:59:15 +0000
commit8df47f8c8d85399cdbe974d83cc5f488bd8603c0 (patch)
tree98eed01767bed012328bfde354559d8cc8ec0edb /configure.ac
parent7606806cd9a75cd2a9efc1b17f86a57230bd92a6 (diff)
configure.ac: Use `pthread_create` to determine if pthread is available
Instead of `pthread_kill`. This is because emscripten supports `pthread_create` but not `pthread_kill`. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@62408 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 800e44ae89..1cd2d581eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2256,7 +2256,7 @@ AS_IF([test "${universal_binary-no}" = yes ], [
AS_IF([test x"$enable_pthread" = xyes], [
for pthread_lib in thr pthread pthreads c c_r root; do
- AC_CHECK_LIB($pthread_lib, pthread_kill,
+ AC_CHECK_LIB($pthread_lib, pthread_create,
rb_with_pthread=yes, rb_with_pthread=no)
AS_IF([test "$rb_with_pthread" = "yes"], [ break; fi
done