summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-03-09 04:24:48 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-03-09 04:24:48 +0000
commit2dafe8df55c7eb7412ffe760dd7f2b4bafcb1da8 (patch)
tree99c5271bddddb8f3da6cf38097799330c66ea971 /configure.ac
parent61a85f91a21eb34cae13c8dbe0136ab8edf1d916 (diff)
configure.ac: --disable-mathn option
* Makefile.in, win32/Makefile.sub: move CANONICALIZATION_FOR_MATHN from config.h which affects all extension libraries to XCFLAGS for the core only. * configure.ac: added --disable-mathn option. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@62705 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f4c1688032..02fec2e0a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,6 @@ AC_SUBST(TEENY)
AC_SUBST(RUBY_PROGRAM_VERSION)
AC_SUBST(RUBY_API_VERSION, '$(MAJOR).$(MINOR)')
RUBY_PATCHLEVEL=`sed -n 's/^#define RUBY_PATCHLEVEL //p' $srcdir/version.h`
-AC_DEFINE(CANONICALIZATION_FOR_MATHN)
dnl checks for alternative programs
AC_CANONICAL_BUILD
RUBY_RM_RECURSIVE
@@ -1398,6 +1397,12 @@ AS_IF([test "$rb_cv_func_exported" != no], [
RUBY_APPEND_OPTION(XCFLAGS, -DRUBY_EXPORT)
+AC_ARG_ENABLE(mathn,
+ AS_HELP_STRING([--disable-mathn], [disable canonicalization for mathn]),
+ [mathn=$enableval], [mathn=yes])
+test "x$mathn" = xyes || mathn=
+AC_SUBST(MATHN, $mathn)
+
AC_CACHE_CHECK(for function name string predefined identifier,
rb_cv_function_name_string,
[rb_cv_function_name_string=no