summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-08-13 02:56:06 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-08-13 02:56:06 +0000
commita20a2b00446d52f86b94e86bc43a1aee3da9f92f (patch)
tree6d8a1faf41787737df83db6dc8468dabb30ab70a /configure.ac
parent8507904385e86d4ce2c913e11e86ea5b71267fdc (diff)
support compressed debug_line
https://blogs.oracle.com/solaris/elf_section_compression-v2 https://gnu.wildebeest.org/blog/mjw/2016/01/13/elf-libelf-compressed-sections-and-elfutils/ git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@64328 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 358acbe261..30d6afa9ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2451,6 +2451,9 @@ AS_IF([test "$rb_cv_binary_elf" = yes], [
AC_CHECK_HEADERS([elf.h elf_abi.h])
AS_IF([test $ac_cv_header_elf_h = yes -o $ac_cv_header_elf_abi_h = yes], [
AC_LIBOBJ([addr2line])
+ AS_IF([test "x$compress_debug_sections" = xzlib], [
+ AC_CHECK_LIB([z], [uncompress])
+ ])
])
])