summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authork0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-19 12:31:02 +0000
committerk0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-19 12:31:02 +0000
commit6e11415b9c3b2e36e91a5979249093426e3c6ad1 (patch)
treefa6d881e95948508ede487bb28335faff169da6c /configure.ac
parent5a8b81fdd37a80da7dd683e7573771810676949b (diff)
configure.ac: add --disable-install-mjit-header
and substitute INSTALL_MJIT_HEADER. This would be convenient as a workaround for user if we found a platform that can't compile Ruby after Ruby 2.6.0 release. common.mk: Install MJIT header only when INSTALL_MJIT_HEADER Makefile.in: ditto win32/Makefile.sub: ditto git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65171 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 50247ca545..7af738d96b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3320,6 +3320,11 @@ AC_SUBST(CAPITARGET)
AS_CASE(["$RDOCTARGET:$CAPITARGET"],[nodoc:nodoc],[INSTALLDOC=nodoc],[INSTALLDOC=all])
AC_SUBST(INSTALLDOC)
+AC_ARG_ENABLE(install-mjit-header,
+ AS_HELP_STRING([--disable-install-mjit-header], [do not install MJIT header]),
+ [INSTALL_MJIT_HEADER=$enableval], [INSTALL_MJIT_HEADER=yes])
+AC_SUBST(INSTALL_MJIT_HEADER)
+
AC_ARG_ENABLE(install-static-library,
AS_HELP_STRING([--disable-install-static-library], [do not install static ruby library]),
[INSTALL_STATIC_LIBRARY=$enableval],
@@ -3981,6 +3986,7 @@ config_summary "debugflags" "$debugflags"
config_summary "warnflags" "$warnflags"
config_summary "strip command" "$STRIP"
config_summary "install doc" "$install_doc"
+config_summary "install MJIT header" "$INSTALL_MJIT_HEADER"
config_summary "man page type" "$MANTYPE"
config_summary "search path" "$search_path"
config_summary "static-linked-ext" ${EXTSTATIC:+"yes"}