summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Wu <XrXr@users.noreply.github.com>2022-12-02 12:24:17 -0500
committerGitHub <noreply@github.com>2022-12-02 12:24:17 -0500
commit1015e69d37b8e75145a3d21e4bd54fa538d1fa68 (patch)
tree08c7b2638f07dbcbe63afae367a59bf90d4c00d1 /configure.ac
parented1e0c2d139d46ab9c9e27dbf004072feda540eb (diff)
YJIT: echo "\n" is not portable
It's unspecified by POSIX. zsh and dash give a newline and bash doesn't substitute it. Attributes don't have to be followed by a newline anyway, so just remove it. [Bug #19174]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 174e395cd6..ae560297ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3755,7 +3755,7 @@ AS_IF([test "$RUSTC" != "no"],
)
dnl Fails in case rustc target doesn't match ruby target.
dnl Can happen on Rosetta, for example.
- AS_IF([echo "#[cfg(target_arch = \"$YJIT_TARGET_ARCH\")]\n fn main() { let x = 1; format!(\"{x}\"); }" |
+ AS_IF([echo "#[cfg(target_arch = \"$YJIT_TARGET_ARCH\")] fn main() { let x = 1; format!(\"{x}\"); }" |
$RUSTC - --emit asm=/dev/null 2>/dev/null],
[YJIT_RUSTC_OK=yes]
)