summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornagachika <nagachika@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2019-03-13 00:06:19 +0000
committernagachika <nagachika@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2019-03-13 00:06:19 +0000
commit7e157824d3211b3d7ecff15db03749c2abe74efc (patch)
treecdebf3195c0d15b874f352105d94c30805baa4cc /configure.ac
parentb2d55db6c56c1338c2e56854a8dd1e2b5da9161f (diff)
merge revision(s) 66779: [Backport #15520]
configure: refuse to build with jemalloc when header is missing [ruby-core:90964] [Bug #15520] Freom: Misty De Meo <mistydemeo@github.com> git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_5@67240 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90ce91bf7c..8a7cee55b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1319,7 +1319,8 @@ AS_IF([test "x$with_jemalloc" = xyes],[
[AC_DEFINE(HAVE_LIBJEMALLOC, 1)], [with_jemalloc=no])
AC_CHECK_HEADER(jemalloc/jemalloc.h, [
AC_DEFINE(RUBY_ALTERNATIVE_MALLOC_HEADER, [<jemalloc/jemalloc.h>])
- ])
+ ],
+ [test x$with_jemalloc = xyes && with_jemalloc=no])
AS_IF([test "x$with_jemalloc" = xno], [
AC_CACHE_CHECK([for jemalloc with JEMALLOC_MANGLE], rb_cv_jemalloc_demangle,
[AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@define JEMALLOC_MANGLE 1