summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsamuel <samuel@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 10:17:24 +0000
committersamuel <samuel@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 10:17:24 +0000
commita2cd16e58ef27cda5652c9715b4e1603c2fd98e5 (patch)
treee359f9d4fd64e450fbb4aee806765795eb5ec85e /configure.ac
parentcdb8f3f996fefc829d663916d4ff1cd4722ab790 (diff)
Expose dependency between cont.c and coroutine implementation.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65863 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a53e3e7ad5..3ae62e9d31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2329,18 +2329,21 @@ AC_MSG_CHECKING(native fiber implementation)
AS_CASE(["$target_cpu-$target_os"],
[x*64-*], [
AC_MSG_RESULT(amd64)
- AC_DEFINE(FIBER_USE_COROUTINE, "coroutine/amd64/Context.h")
+ COROUTINE_H=coroutine/amd64/Context.h
+ AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
AC_LIBOBJ([coroutine/amd64/Context])
],
[*86-*], [
AC_MSG_RESULT(x86)
- AC_DEFINE(FIBER_USE_COROUTINE, "coroutine/x86/Context.h")
+ COROUTINE_H=coroutine/x86/Context.h
+ AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
AC_LIBOBJ([coroutine/x86/Context])
]
[*], [
AC_MSG_RESULT(no)
]
)
+AC_SUBST(X_FIBER_COROUTINE_H, [$COROUTINE_H])
AS_IF([test x"$enable_pthread" = xyes], [
for pthread_lib in thr pthread pthreads c c_r root; do