summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2022-02-19 16:02:29 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2022-02-19 23:32:52 +0900
commit131154f878b7f63277bd97520500414047a814fa (patch)
tree86550107529a3a5357517b0679c37bc1cb6705ff /configure.ac
parent6e6ee1e6b3ce70a325043c502918c1eb9529b4a2 (diff)
Define `HAVE___BUILTIN_UNREACHABLE` instead of `UNREACHABLE`
`UNREACHABLE` in ruby/internal/has/builtin.h is only used as just a flag now, and redefined in ruby/backward/2/assume.h then.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/5577
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4b8dce1a2f..916e9a4e98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1677,7 +1677,7 @@ AS_IF([test "$GCC" = yes], [
])
])
AS_IF([test "$rb_cv_func___builtin_unreachable" = yes], [
- AC_DEFINE_UNQUOTED(UNREACHABLE, [__builtin_unreachable()])
+ AC_DEFINE(HAVE___BUILTIN_UNREACHABLE)
])
}