summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-01-19 01:45:36 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-01-19 01:45:36 +0000
commit3ca0948f68d1055cd980992dcb68deced0f4d704 (patch)
tree961c2602e81c6dc5f73e46a3a2d61565c4da16d8 /configure.ac
parent09b4d6e8cd50dca07997d40b7e04d6652a9a4d43 (diff)
INFINITY is float. That of double is HUGE_VAL.
It seems HUGE_VAL is already used. Why not eliminate INTINITY. NAN is also float. That of double is called nan(). This is also fixed. Signed-off-by: Urabe, Shyouhei <shyouhei@ruby-lang.org> git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@61938 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 248e72ce61..4565be98ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -805,7 +805,7 @@ AS_IF([test "$GCC:${warnflags+set}:no" = yes::no], [
])
RUBY_TRY_CFLAGS(-Qunused-arguments, [RUBY_APPEND_OPTIONS(rb_cv_wsuppress_flags, -Qunused-arguments)])
-for n in infinity nan; do
+for n in huge_val infinity nan; do
m=AS_TR_CPP($n)
AC_CACHE_CHECK([whether $m is available without C99 option], rb_cv_$n,
[AC_COMPILE_IFELSE(
@@ -2393,6 +2393,7 @@ AC_CHECK_FUNCS(memmem)
AC_CHECK_FUNCS(mkfifo)
AC_CHECK_FUNCS(mknod)
AC_CHECK_FUNCS(mktime)
+AC_CHECK_FUNCS(nanf) # We need nan(), but HAVE_NAN conflicts...
AC_CHECK_FUNCS(openat)
AC_CHECK_FUNCS(pipe2)
AC_CHECK_FUNCS(poll)