summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornagachika <nagachika@ruby-lang.org>2022-10-19 22:20:49 +0900
committernagachika <nagachika@ruby-lang.org>2022-10-19 22:20:49 +0900
commit1db6249c66291ad2464f89768d24d850dbf98901 (patch)
treec91b12bfcfec8420ce07eec605aa927ea20486a3 /configure.ac
parent3e05dff67cfa734eff18f0edf826ab2876b210b4 (diff)
merge revision(s) 1f91dcdab3b530dde93fa29fba8bf60683cd8056:
Define BOOTSTRAPRUBY from HAVE_BASERUBY --- common.mk | 1 + configure.ac | 8 -------- template/Makefile.in | 7 +++++-- win32/Makefile.sub | 6 ++++-- 4 files changed, 10 insertions(+), 12 deletions(-)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index efdd92698a..fba306958d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3312,8 +3312,6 @@ for var in bindir includedir libdir rubylibprefix; do
done
BTESTRUBY='$(MINIRUBY)'
-BOOTSTRAPRUBY='$(BASERUBY)'
-BOOTSTRAPRUBY_COMMAND='$(BOOTSTRAPRUBY)'
AS_IF([test x"$cross_compiling" = xyes], [
test x"$MINIRUBY" = x && MINIRUBY="${RUBY-$BASERUBY} -I`$CHDIR .; pwd` "-r'$(arch)-fake'
XRUBY_LIBDIR=`${RUBY-$BASERUBY} -rrbconfig -e ['puts RbConfig::CONFIG["libdir"]']`
@@ -3326,7 +3324,6 @@ AS_IF([test x"$cross_compiling" = xyes], [
RUNRUBY_COMMAND='$(MINIRUBY) -I`cd $(srcdir)/lib; pwd`'
RUNRUBY='$(RUNRUBY_COMMAND)'
XRUBY='$(MINIRUBY)'
- BOOTSTRAPRUBY_COMMAND='$(BOOTSTRAPRUBY) -r./$(arch)-fake'
TEST_RUNNABLE=no
CROSS_COMPILING=yes
AC_DEFINE(CROSS_COMPILING, 1)
@@ -3337,9 +3334,6 @@ AS_IF([test x"$cross_compiling" = xyes], [
RUNRUBY_COMMAND='$(MINIRUBY) $(tooldir)/runruby.rb --extout=$(EXTOUT) $(RUNRUBYOPT)'
RUNRUBY='$(RUNRUBY_COMMAND) --'
XRUBY='$(RUNRUBY)'
- AS_CASE(["$HAVE_BASERUBY"],
- [yes], [BOOTSTRAPRUBY_COMMAND='$(BOOTSTRAPRUBY) -r./$(arch)-fake'],
- [BOOTSTRAPRUBY='$(MINIRUBY)'])
TEST_RUNNABLE=yes
CROSS_COMPILING=no
])
@@ -3351,8 +3345,6 @@ AC_SUBST(PREP)
AC_SUBST(RUNRUBY_COMMAND)
AC_SUBST(RUNRUBY)
AC_SUBST(XRUBY)
-AC_SUBST(BOOTSTRAPRUBY)
-AC_SUBST(BOOTSTRAPRUBY_COMMAND)
AC_SUBST(EXTOUT, [${EXTOUT=.ext}])
FIRSTMAKEFILE=""