summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-18 09:21:05 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-18 09:21:05 +0000
commit88a7271de4e6a8b32bbbaa83eca84bf71c888f65 (patch)
treebaa6c59e4716f3ae1f36617799a33d42abe24d86 /configure.ac
parent8183cd2f1df71d660d3cbc633c06b6e4c77ad91b (diff)
configure.ac: do not overwrite -std=
Set -std=gnu99 only when no such compiler flag(s) are set in any compiler-related environment variables. This enables users to specify something more modern, say, -std=c11. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65154 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e887ddd3bf..50247ca545 100644
--- a/configure.ac
+++ b/configure.ac
@@ -626,6 +626,9 @@ AS_IF([test "$GCC" = yes], [
],
[
# ANSI (no XCFLAGS because this is C only)
+ rb_tmp_std_check=`echo $CC $CFLAGS $optflags $warnflags $debugflags | fgrep std= | tr -d '\015'`
+ AS_IF([test "x$rb_tmp_std_check" = "x"],
+ [
for ansi_options in -std=gnu99; do
RUBY_TRY_CFLAGS(${ansi_options}, [
RUBY_APPEND_OPTIONS(warnflags, ${ansi_options})
@@ -633,6 +636,7 @@ AS_IF([test "$GCC" = yes], [
], [ansi_options=])
test "x${ansi_options}" = x || break
done
+ ])
])
# suppress annoying -Wstrict-overflow warnings