summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYuta Saito <kateinoigakukun@gmail.com>2022-01-15 22:22:30 +0900
committerYuta Saito <kateinoigakukun@gmail.com>2022-01-19 11:19:06 +0900
commita4b73f1ba88b4d126569ba5ab295c0eb5f121662 (patch)
tree242a8751b69efb6067e206f8d5e7f0a3e83dbecb /configure.ac
parent7ee786388ae0d6f8c8cea7bf012cc11fdb5b534a (diff)
[wasm] add coroutine/asyncify implementation
set the default coroutine_type as asyncify when wasi
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/5407
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f6f88901bd..35b8c47956 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2624,6 +2624,9 @@ AS_CASE([$coroutine_type], [yes|''], [
[*-emscripten*], [
coroutine_type=emscripten
],
+ [*-wasi*], [
+ coroutine_type=asyncify
+ ],
[
AC_CHECK_FUNCS([getcontext swapcontext makecontext],
[coroutine_type=ucontext],