summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Evans <code@jeremyevans.net>2021-10-19 12:59:39 -0700
committerJeremy Evans <code@jeremyevans.net>2022-08-09 22:13:17 -0700
commit357352af5ee37bf31ba4468ee242ea5a10158461 (patch)
tree9ce006adc7e6be67c55893cb83132dab32d47090 /configure.ac
parentff07e5c264c82f73b0368dd0bc2ae39f78678519 (diff)
Do not enable RUBY_DEVEL by RUBY_PATCHLEVEL
This makes RUBY_DEVEL not enabled automatically. It still can be enabled manually. Test manually using RUBY_DEVEL in CI. Implements [Feature #17468]
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4993
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9ed0c1ef9e..575bdf6631 100644
--- a/configure.ac
+++ b/configure.ac
@@ -622,8 +622,7 @@ AS_IF([test "$fdeclspec" = yes], [
RUBY_APPEND_OPTIONS(CXXFLAGS, -fdeclspec)
])
-AS_CASE([$RUBY_PATCHLEVEL], [-*],
- [RUBY_DEVEL=yes], [RUBY_DEVEL=no])
+AS_IF([test "x$RUBY_DEVEL" != xyes], [RUBY_DEVEL=no])
particular_werror_flags=$RUBY_DEVEL
AC_ARG_ENABLE(werror,
AS_HELP_STRING([--disable-werror],