summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-05-06 11:15:24 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-05-06 11:30:37 +0900
commita1fdc5f71cf0ad8254282e34b2a8b7dce11722ba (patch)
tree728ffbd8e6bab095993ed9e226d04efb0856f25a /configure.ac
parent921d8ac99d264fec26e15b75ea4fbe024aef281b (diff)
Check only whether PAGE_SIZE is compile-time const
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 8 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index dd553b22a4..e781da0a31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2732,24 +2732,18 @@ AS_CASE([$target_os],
[AC_CHECK_HEADERS([sys/user.h])]
)
AS_IF([test "x$ac_cv_func_mmap:$ac_cv_header_sys_user_h" = xyes:yes], [
- AC_CACHE_CHECK([PAGE_SIZE is defined], rb_cv_page_size,
+ AC_CACHE_CHECK([whether PAGE_SIZE is compile-time const], rb_cv_const_page_size,
[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
@%:@include <sys/user.h>
typedef char conftest_page[PAGE_SIZE];
]], [[]])],
- [rb_cv_page_size=const],
- [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- @%:@include <sys/user.h>
- ]], [[
- int page_size = (int)PAGE_SIZE;
- (void)page_size;
- ]])],
- [rb_cv_page_size=variable], [rb_cv_page_size=no])])])
- AS_IF([test "x$rb_cv_page_size" = xconst],
- [AC_DEFINE(HAVE_CONST_PAGE_SIZE, 1)],
- [AC_DEFINE(HAVE_CONST_PAGE_SIZE, 0)]
- )
-], [AC_DEFINE(HAVE_CONST_PAGE_SIZE, 0)])
+ [rb_cv_const_page_size=yes],
+ [rb_cv_const_page_size=no])])
+])
+AS_IF([test "x$rb_cv_const_page_size" = xyes],
+ [AC_DEFINE(HAVE_CONST_PAGE_SIZE, 1)],
+ [AC_DEFINE(HAVE_CONST_PAGE_SIZE, 0)]
+)
}
: "runtime section" && {