summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-09-30 18:24:37 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-09-30 19:22:08 +0900
commit912a8dcfc5369d840dcd6bf0f88ee0bac7d902d6 (patch)
tree3f2097821db7dcb55371dd54b5997f82a9128fcd /configure.ac
parent90f2ab9d62860d7b3413fb363403c1d16b4a860e (diff)
Needs `AC_PROG_CC`
Although `AC_PROG_CC_C99` has been obsolete, `AC_PROG_CC` is not and the latter is necessary not to make C++ compiler mandatory.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4914
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b24a8f59b0..c7059ee1ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,7 +218,7 @@ rb_test_CXXFLAGS=${CXXFLAGS+yes}
# BSD's ports and MacPorts prefix GNU binutils with 'g'
dnl Seems necessarily in order to add -std=gnu99 option for gcc 4.9.
-m4_version_prereq([2.70], [], [AC_PROG_CC_C99])
+m4_version_prereq([2.70], [AC_PROG_CC], [AC_PROG_CC_C99])
AC_PROG_CXX
AC_PROG_CPP