summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 00:39:07 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 00:39:07 +0000
commitd7d0ee10653afad2ace63cbf557eb0204097e1d7 (patch)
tree19e13d55820d6bd1ada4dc80fa83bf392a1f021a /configure.ac
parentb410d32185926e337543a8224ea4058e22e8bdb6 (diff)
Check -fcf-protection
* configure.ac: Check if CFLAGS actually includes -fcf-protection instead of checking if the flag is valid by RUBY_TRY_CFLAGS. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65819 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a0882a0c0f..f4be92039d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1002,8 +1002,7 @@ main()
ac_cv_func___builtin_setjmp=no
])
# With gcc-8's -fcf-protection, MJIT's __builtin_longjmp fails.
- # TODO: Check if CFLAGS actually includes -fcf-protection instead of using RUBY_TRY_CFLAGS
- RUBY_TRY_CFLAGS(-fcf-protection, [cf_protection=yes], [cf_protection=no])
+ AS_CASE(["$CC $CFLAGS "], [*" -fcf-protection "*], [cf_protection=yes], [cf_protection=no])
AS_IF([test "$cf_protection" = yes], [
ac_cv_func___builtin_setjmp=no
])