summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorko1 <ko1@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-20 08:00:42 +0000
committerko1 <ko1@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-20 08:00:42 +0000
commit0b19e15a1239bff9ae854f522f954206ec910cf8 (patch)
treebb782c2ec272b6197e5dbff23ad900107d553105 /configure.ac
parent93c4f8b360269b6eace2c92db911cf554d436deb (diff)
rename configure option `--disable-mjit` to `--disable-mjit-support`
* configure.ac: rename configure option `--disable-mjit` to `--disable-mjit-support` because `--disable-mjit` is ambiguous that runtime MJIT default enable option or supporting MJIT features. `ENABLE_MJIT` is also renamed to `MJIT_SUPPORT` * Makefile.in: catch up this fix. * common.mk: ditto. * test/ruby/test_jit.rb: ditto. * win32/Makefile.sub: catch up this fix on mswin. * tool/mkconfig.rb: fix to pass `MJIT_SUPPORT` key. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65217 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 5191a91eee..70d8ed9cc3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3325,16 +3325,16 @@ AC_SUBST(CAPITARGET)
AS_CASE(["$RDOCTARGET:$CAPITARGET"],[nodoc:nodoc],[INSTALLDOC=nodoc],[INSTALLDOC=all])
AC_SUBST(INSTALLDOC)
-AC_ARG_ENABLE(mjit,
- AS_HELP_STRING([--disable-mjit], [disable MJIT features]),
- [ENABLE_MJIT=$enableval
- AS_IF([test x"$enable_mjit" = "xyes"],
+AC_ARG_ENABLE(mjit-support,
+ AS_HELP_STRING([--disable-mjit-support], [disable MJIT features]),
+ [MJIT_SUPPORT=$enableval
+ AS_IF([test x"$enable_mjit_support" = "xyes"],
[AC_DEFINE(USE_MJIT, 1)],
[AC_DEFINE(USE_MJIT, 0)])],
- [ENABLE_MJIT=yes
+ [MJIT_SUPPORT=yes
AC_DEFINE(USE_MJIT, 1)])
-AC_SUBST(ENABLE_MJIT)
+AC_SUBST(MJIT_SUPPORT)
AC_ARG_ENABLE(install-static-library,
AS_HELP_STRING([--disable-install-static-library], [do not install static ruby library]),
@@ -3997,7 +3997,7 @@ config_summary "debugflags" "$debugflags"
config_summary "warnflags" "$warnflags"
config_summary "strip command" "$STRIP"
config_summary "install doc" "$install_doc"
-config_summary "enable MJIT" "$ENABLE_MJIT"
+config_summary "MJIT support" "$MJIT_SUPPORT"
config_summary "man page type" "$MANTYPE"
config_summary "search path" "$search_path"
config_summary "static-linked-ext" ${EXTSTATIC:+"yes"}