summaryrefslogtreecommitdiff
path: root/ext
AgeCommit message (Collapse)Author
2019-12-17[ruby/io-console] Disable implementation-defined special control charactersNobuyoshi Nakada
In raw mode with interrupt enabled. https://github.com/ruby/io-console/commit/e9e8e3ff17
2019-12-17[ruby/io-console] Removed dead codeNobuyoshi Nakada
https://github.com/ruby/io-console/commit/a49462ed97
2019-12-12Import json-2.3.0 from flori/jsonHiroshi SHIBATA
2019-12-10[ruby/io-console] update depend for f9c0fe77c0eNobuyoshi Nakada
2019-12-10[ruby/io-console] bump up to 0.5.1Nobuyoshi Nakada
2019-12-10[ruby/io-console] Suppress an unused-variable warningNobuyoshi Nakada
https://github.com/ruby/io-console/commit/ae5c72e481
2019-12-10[ruby/io-console] Use rb_thread_call_without_gvl instead of the deprecated ↵Nobuyoshi Nakada
function https://github.com/ruby/io-console/commit/21338ab287
2019-12-10[ruby/io-console] Warn vtime option without intr flagNobuyoshi Nakada
https://github.com/ruby/io-console/commit/499ff3de48
2019-12-10[ruby/io-console] bump up to 0.5.0Nobuyoshi Nakada
2019-12-05ext/openssl/extconf.rb: check with -Werror=deprecated-declarationsNobuyoshi Nakada
This reverts commit 0d7d8b2989e1738dd902d354cc41186899e6b71e, but restore `$warnflags` without the flag, to get rid of using deprecated functions.
2019-12-05ext/psych/extconf.rb: braced VPATH is for nmake onlyNobuyoshi Nakada
2019-12-05ext/openssl/extconf.rb: do not use -Werror=deprecated-declarationsYusuke Endoh
It fails to build on Solaris: ``` ossl_cipher.c: 関数 ‘ossl_cipher_init’ 内: ossl_cipher.c:228:2: エラー: ‘EVP_md5’ is deprecated [-Werror=deprecated-declarations] 228 | EVP_BytesToKey(EVP_CIPHER_CTX_cipher(ctx), EVP_md5(), iv, | ^~~~~~~~~~~~~~ In file included from /usr/include/openssl/x509.h:73, from /usr/include/openssl/x509v3.h:63, from ossl.h:23, from ossl_cipher.c:10: /usr/include/openssl/evp.h:732:26: 備考: ここで宣言されています 732 | DEPRECATED const EVP_MD *EVP_md5(void); | ^~~~~~~ ``` I agree that `-Werror=` is a good habit, but adding it by default is too aggressive.
2019-12-04new_cond before mon_initializeKoichi Sasada
MonitorMixin#new_cond can be called before mon_initialize, so we need to initialize `@monitor` before it. https://bugs.ruby-lang.org/issues/16255#note-4
2019-12-04[ruby/io-console] Fixed `intr: false` mode on WindowsNobuyoshi Nakada
https://github.com/ruby/io-console/commit/4c172c01aa
2019-11-30[ruby/zlib] Bump version to 1.1.0Hiroshi SHIBATA
https://github.com/ruby/zlib/commit/5af77c1ee8
2019-11-30[ruby/gdbm] Bump version to 2.1.0Hiroshi SHIBATA
https://github.com/ruby/gdbm/commit/ffb2b063a3
2019-11-30[ruby/etc] Bump version to 1.1.0Hiroshi SHIBATA
https://github.com/ruby/etc/commit/78987ce56a
2019-11-30[ruby/dbm] Bump version to 1.1.0Hiroshi SHIBATA
https://github.com/ruby/dbm/commit/163078359d
2019-11-30[ruby/readline-ext] Prepare to gem releaseHiroshi SHIBATA
https://github.com/ruby/readline-ext/commit/e5b969215a
2019-11-30[ruby/stringio] Bump version to 0.1.0Hiroshi SHIBATA
https://github.com/ruby/stringio/commit/4c1e267e1a
2019-11-30[ruby/stringio] RbConfig::LIMITS only provide after Ruby 2.5Hiroshi SHIBATA
https://github.com/ruby/stringio/commit/1fed3aacd3
2019-11-30[ruby/date] Bump version to 3.0.0Hiroshi SHIBATA
https://github.com/ruby/date/commit/202b2dad93
2019-11-29check interrupts at each frame pop timing.Koichi Sasada
Asynchronous events such as signal trap, finalization timing, thread switching and so on are managed by "interrupt_flag". Ruby's threads check this flag periodically and if a thread does not check this flag, above events doesn't happen. This checking is CHECK_INTS() (related) macro and it is placed at some places (laeve instruction and so on). However, at the end of C methods, C blocks (IMEMO_IFUNC) etc there are no checking and it can introduce uninterruptible thread. To modify this situation, we decide to place CHECK_INTS() at vm_pop_frame(). It increases interrupt checking points. [Bug #16366] This patch can introduce unexpected events...
2019-11-29Nmake needs `VPATH`Nobuyoshi Nakada
2019-11-29Add dependency on bundled yaml.h when usingNobuyoshi Nakada
2019-11-27Fix documentation of `MonitorMixin#new_cond` [ci skip] (#2707)y-yagi
Since https://github.com/ruby/ruby/pull/2576, `new_cond` uses the Monitor object, not the receiver.
2019-11-26Allow `$10` and more in the Ripper DSLNobuyoshi Nakada
2019-11-22Revert "Update dependencies"Vít Ondruch
This reverts commit e1b234148829f65bea9f5ecc7018beb782ea6023. This allows to build Psych against system libyaml again on Fedora. [Bug #16359]
2019-11-22Check -1 arity for C++Nobuyoshi Nakada
2019-11-20Revert the line for nextafter.c for FreeBSD makeNobuyoshi Nakada
2019-11-19Configure static extensions only if in chargeNobuyoshi Nakada
Get rid of races in parallel configuration when using the ext/Setup file.
2019-11-18Update dependenciesNobuyoshi Nakada
2019-11-18[ruby/strscan] Remove taint supportJeremy Evans
Ruby 2.7 deprecates taint and it no longer has an effect. The lack of taint support should not cause a problem in previous Ruby versions. Notes: Merged: https://github.com/ruby/ruby/pull/2476
2019-11-18[ruby/openssl] Remove taint supportJeremy Evans
Ruby 2.7 deprecates taint and it no longer has an effect. The lack of taint support should not cause a problem in previous Ruby versions. Notes: Merged: https://github.com/ruby/ruby/pull/2476
2019-11-18[ruby/io-console] Remove taint supportJeremy Evans
Ruby 2.7 deprecates taint and it no longer has an effect. The lack of taint support should not cause a problem in previous Ruby versions. Notes: Merged: https://github.com/ruby/ruby/pull/2476
2019-11-18[ruby/etc] Remove taint supportJeremy Evans
Ruby 2.7 deprecates taint and it no longer has an effect. The lack of taint support should not cause a problem in previous Ruby versions. Still untaint the tmpdir object on Ruby <2.7, as returning a tainted string there could cause problems. Notes: Merged: https://github.com/ruby/ruby/pull/2476
2019-11-18Deprecate taint/trust and related methods, and make the methods no-opsJeremy Evans
This removes the related tests, and puts the related specs behind version guards. This affects all code in lib, including some libraries that may want to support older versions of Ruby. Notes: Merged: https://github.com/ruby/ruby/pull/2476
2019-11-18Warn on access/modify of $SAFE, and remove effects of modifying $SAFEJeremy Evans
This removes the security features added by $SAFE = 1, and warns for access or modification of $SAFE from Ruby-level, as well as warning when calling all public C functions related to $SAFE. This modifies some internal functions that took a safe level argument to no longer take the argument. rb_require_safe now warns, rb_require_string has been added as a version that takes a VALUE and does not warn. One public C function that still takes a safe level argument and that this doesn't warn for is rb_eval_cmd. We may want to consider adding an alternative method that does not take a safe level argument, and warn for rb_eval_cmd. Notes: Merged: https://github.com/ruby/ruby/pull/2476
2019-11-13Update comment of Ripper.lexYuichiro Kaneko
This is follow up of 1f7cb4bee9.
2019-11-12Revert "Method reference operator"Nobuyoshi Nakada
This reverts commit 67c574736912003c377218153f9d3b9c0c96a17b. [Feature #16275]
2019-11-12[ruby/bigdecimal] Remove taint checkingJeremy Evans
This removes the taint checking. Taint support is deprecated in Ruby 2.7 and has no effect. I don't think removing the taint checks in earlier ruby versions will cause any problems. https://github.com/ruby/bigdecimal/commit/1918d466f3
2019-11-12[ruby/psych] Add a note about safe_loadAaron Patterson
https://github.com/ruby/psych/commit/0910ae5575
2019-11-12[ruby/psych] Remove taint supportJeremy Evans
Ruby 2.7 deprecates taint and it no longer has an effect. The lack of taint support should not cause a problem in previous Ruby versions. I'm not sure if the untaint calls in deduplicate are still needed after the removal of tainting in the parser. If they are not needed, they should be removed. https://github.com/ruby/psych/commit/73c1a2b4e0
2019-11-12[ruby/psych] Set required_ruby_version to 2.4.0Jean Boussier
https://github.com/ruby/psych/commit/4f1746a3c6
2019-11-12Monitor#exit: check monitor ownership.Koichi Sasada
Monitor#exit should be called by only onwer Thread. However, there is not check for it.
2019-11-11Removed duplicate fileNobuyoshi Nakada
"./tests/test_helper.rb" and "tests/test_helper.rb" in `s.files` are same.
2019-11-09Remove unneeded exec bits from some filesDavid Rodríguez
I noticed that some files in rubygems were executable, and I could think of no reason why they should be. In general, I think ruby files should never have the executable bit set unless they include a shebang, so I run the following command over the whole repo: ```bash find . -name '*.rb' -type f -executable -exec bash -c 'grep -L "^#!" $1 || chmod -x $1' _ {} \; ``` Notes: Merged: https://github.com/ruby/ruby/pull/2662
2019-11-09Promote readline to default gems named readline-extHiroshi SHIBATA
2019-11-07Suppress unused variable warningNobuyoshi Nakada
2019-11-05Adjust a fucntion signatureNobuyoshi Nakada