summaryrefslogtreecommitdiff
path: root/yjit/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'yjit/Cargo.toml')
-rw-r--r--yjit/Cargo.toml15
1 files changed, 12 insertions, 3 deletions
diff --git a/yjit/Cargo.toml b/yjit/Cargo.toml
index a5208049cb..0b2e286cc9 100644
--- a/yjit/Cargo.toml
+++ b/yjit/Cargo.toml
@@ -6,7 +6,7 @@
name = "yjit"
version = "0.1.0" # YJIT version
edition = "2021" # Rust 2021 edition to compile with
-rust-version = "1.58.1" # Minimally supported rust version
+rust-version = "1.58.0" # Minimally supported rust version
publish = false # Don't publish to crates.io
[lib]
@@ -15,14 +15,13 @@ crate-type = ["staticlib"]
[dependencies]
# No required dependencies to simplify build process. TODO: Link to yet to be
# written rationale. Optional For development and testing purposes
-capstone = { version = "0.10.0", optional = true }
+capstone = { version = "0.12.0", optional = true }
[features]
# NOTE: Development builds select a set of these via configure.ac
# For debugging, `make V=1` shows exact cargo invocation.
disasm = ["capstone"]
stats = []
-asm_comments = []
[profile.dev]
opt-level = 0
@@ -30,6 +29,12 @@ debug = true
debug-assertions = true
overflow-checks = true
+[profile.dev_nodebug]
+inherits = "dev"
+
+[profile.stats]
+inherits = "release"
+
[profile.release]
# NOTE: --enable-yjit builds use `rustc` without going through Cargo. You
# might want to update the `rustc` invocation if you change this profile.
@@ -37,3 +42,7 @@ opt-level = 3
# The extra robustness that comes from checking for arithmetic overflow is
# worth the performance cost for the compiler.
overflow-checks = true
+# Generate debug info
+debug = true
+# Use ThinLTO. Much smaller output for a small amount of build time increase.
+lto = "thin"