summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 24035c7c1a..b846524fdc 100644
--- a/configure.in
+++ b/configure.in
@@ -1203,9 +1203,16 @@ main()
if test "$rb_cv_broken_crypt" = yes; then
AC_DEFINE(BROKEN_CRYPT, 1)
fi
+ POSTLINK=""
AC_CHECK_PROGS(codesign, codesign)
+ AC_CHECK_PROGS(dsymutil, dsymutil)
if test -n "$codesign"; then
- POSTLINK="test -z '\$(RUBY_CODESIGN)' || $codesign -s '\$(RUBY_CODESIGN)' -f \$@"
+ POSTLINK="{ test -z '\$(RUBY_CODESIGN)' || $codesign -s '\$(RUBY_CODESIGN)' -f \$@; }${POSTLINK:+; $POSTLINK}"
+ fi
+ if test -n "$dsymutil"; then
+ POSTLINK="$dsymutil \$@${POSTLINK:+; $POSTLINK}"
+ fi
+ if test -n "${POSTLINK}"; then
LINK_SO="$LINK_SO
\$(POSTLINK)"
fi