summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 041018e0d2..bd841c434c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,16 +1,15 @@
-
dnl Process this file with autoconf to produce a configure script.
AC_INIT(ruby.h)
PROGS="ruby"
AC_SUBST(PROGS)dnl
AC_PROG_CC
AC_GCC_TRADITIONAL
-if test $GCC -eq 1 ; then
+if test "$GCC" = 1 ; then
DBM=-fpcc-struct-return
fi
AC_SUBST(DBM)dnl
if test "$HOSTTYPE" = sparc; then
- if test $GCC -eq 1 ; then
+ if test "$GCC" = 1 ; then
STATIC=-static
else
STATIC=-Bstatic
@@ -27,7 +26,8 @@ AC_GETGROUPS_T
AC_RETSIGTYPE
AC_HAVE_FUNCS(getopt_long memmove strerror strtoul strdup strstr)
AC_HAVE_FUNCS(setenv fmod killpg mkdir strftime socket random)
-AC_HAVE_FUNCS(wait4 waitpid syscall)
+AC_HAVE_FUNCS(wait4 waitpid syscall getcwd)
+AC_HAVE_FUNCS(getpriority sigprocmask)
if echo $DEFS | grep "HAVE_SETENV" 2>&1 > /dev/null; then
:
else
@@ -38,13 +38,15 @@ if echo $DEFS | grep "HAVE_STRFTIME" 2>&1 > /dev/null; then
else
AC_TIMEZONE
AC_COMPILE_CHECK([daylight], [],
- [extern int daylight; int i; i = daylight;], AC_DEFINE(HAVE_DAYLIGHT))
+ [extern int daylight; int i = daylight;], AC_DEFINE(HAVE_DAYLIGHT))
fi
AC_ALLOCA
AC_WORDS_BIGENDIAN
AC_ST_BLKSIZE
AC_ST_BLOCKS
AC_ST_RDEV
+AC_COMPILE_CHECK([std stdio], [#include <stdio.h>],
+[stdin->_cnt > 0;], AC_DEFINE(STDSTDIO))
AC_COMPILE_CHECK([pw_change in struct passwd], [#include <pwd.h>],
[struct passwd pw; pw.pw_change;], AC_DEFINE(PW_CHANGE))
AC_COMPILE_CHECK([pw_quota in struct passwd], [#include <pwd.h>],