summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 900cd28402..367a072720 100644
--- a/configure.ac
+++ b/configure.ac
@@ -238,6 +238,10 @@ AS_IF([test "$GCC" = yes], [
linker_flag=
])
+AS_IF([test "$GCC" = yes -a "$gcc_major" -lt 3 ], [
+ AC_MSG_ERROR([too old GCC])
+])
+
RUBY_PROG_GNU_LD
RUBY_CPPOUTFILE