summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ext/psych/lib/psych/versions.rb2
-rw-r--r--ext/psych/psych.gemspec3
2 files changed, 3 insertions, 2 deletions
diff --git a/ext/psych/lib/psych/versions.rb b/ext/psych/lib/psych/versions.rb
index b01fa7d..455a014 100644
--- a/ext/psych/lib/psych/versions.rb
+++ b/ext/psych/lib/psych/versions.rb
@@ -1,7 +1,7 @@
# frozen_string_literal: false
module Psych
# The version is Psych you're using
- VERSION = '2.2.1'
+ VERSION = '2.2.2'
if RUBY_ENGINE == 'jruby'
DEFAULT_SNAKEYAML_VERSION = '1.17'.freeze
diff --git a/ext/psych/psych.gemspec b/ext/psych/psych.gemspec
index df91ff4..9597e98 100644
--- a/ext/psych/psych.gemspec
+++ b/ext/psych/psych.gemspec
@@ -1,4 +1,5 @@
# -*- encoding: utf-8 -*-
+$:.unshift File.expand_path("../lib", __FILE__)
require 'psych'
Gem::Specification.new do |s|
@@ -33,7 +34,7 @@ DESCRIPTION
if RUBY_ENGINE == 'jruby'
s.platform = 'java'
s.files.concat ["ext/java/PsychEmitter.java", "ext/java/PsychLibrary.java", "ext/java/PsychParser.java", "ext/java/PsychToRuby.java", "ext/java/PsychYamlTree.java", "lib/psych_jars.rb", "lib/psych.jar"]
- s.requirements = "jar org.yaml:snakeyaml, #{Psych::DEFAULT_SNAKEYAML_VERSION}"
+ s.requirements = "jar org.yaml:snakeyaml, 1.17"
s.add_dependency 'jar-dependencies', '>= 0.1.7'
s.add_development_dependency 'ruby-maven'
else