summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog5
-rw-r--r--ext/openssl/extconf.rb10
2 files changed, 6 insertions, 9 deletions
diff --git a/ChangeLog b/ChangeLog
index e5e1a66..da408c5 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+Tue Jan 20 14:48:13 2004 GOTOU Yuuzou <gotoyuzo@notwork.org>
+
+ * ext/openssl/extconf.rb: should check <openssl/conf_api.h> instead
+ of OPENSSL_VERSION_NUMBER. [ruby-list:39056]
+
Tue Jan 20 14:43:17 2004 Dave Thomas <dave@pragprog.com>
* lib/base64.rb: Add RDoc
diff --git a/ext/openssl/extconf.rb b/ext/openssl/extconf.rb
index afcb038..47fa722 100644
--- a/ext/openssl/extconf.rb
+++ b/ext/openssl/extconf.rb
@@ -33,8 +33,6 @@ if with_config("debug") or enable_config("debug")
end
end
-
-
message "=== Checking for system dependent stuff... ===\n"
have_library("nsl", "t_open")
have_library("socket", "socket")
@@ -58,13 +56,7 @@ if !result
end
end
-check_opensslv = <<_end_of_src_
-#include <openssl/opensslv.h>
-#if OPENSSL_VERSION_NUMBER < 0x0090600fL
-# error too old
-#endif
-_end_of_src_
-if !try_compile(check_opensslv)
+unless have_header("openssl/conf_api.h")
message "OpenSSL 0.9.6 or later required.\n"
exit 1
end