summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog6
-rw-r--r--lib/rake/application.rb1
-rw-r--r--lib/rake/dsl_definition.rb8
-rw-r--r--lib/rake/version.rb2
-rw-r--r--test/rake/helper.rb1
-rw-r--r--test/rake/test_rake_dsl.rb4
-rw-r--r--test/rake/test_rake_functional.rb2
7 files changed, 18 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index 0232b3cb756..dd6856f240c 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+Sat Aug 13 01:56:11 2011 Eric Hodel <drbrain@segment7.net>
+
+ * lib/rake: Update to Rake 0.9.2.2. Prevent pollution of toplevel
+ namespace by Commands. Remove unused variable and debugging
+ statement in tests.
+
Fri Aug 12 11:39:35 2011 KOSAKI Motohiro <kosaki.motohiro@gmail.com>
* configure.in: Desbribe "no" configure option for site_ruby
diff --git a/lib/rake/application.rb b/lib/rake/application.rb
index a4954f27e77..2079fb9be66 100644
--- a/lib/rake/application.rb
+++ b/lib/rake/application.rb
@@ -348,6 +348,7 @@ module Rake
],
['--rakelibdir', '--rakelib', '-R RAKELIBDIR',
"Auto-import any .rake files in RAKELIBDIR. (default is 'rakelib')",
+ # HACK Use File::PATH_SEPARATOR
lambda { |value| options.rakelib = value.split(':') }
],
['--require', '-r MODULE', "Require MODULE before executing rakefile.",
diff --git a/lib/rake/dsl_definition.rb b/lib/rake/dsl_definition.rb
index 3294f9e6c0f..6d9a6b88f3a 100644
--- a/lib/rake/dsl_definition.rb
+++ b/lib/rake/dsl_definition.rb
@@ -144,10 +144,12 @@ module Rake
Rake.application.add_import(fn)
end
end
+
end
+ DeprecatedCommands = Object.new.extend(DSL)
+
module DeprecatedObjectDSL # :nodoc:
- Commands = Object.new.extend DSL
DSL.private_instance_methods(false).each do |name|
line = __LINE__+1
class_eval %{
@@ -160,8 +162,8 @@ module Rake
end
$stderr.puts "WARNING: DSL method \#{self.class}##{name} called at \#{caller.first}"
end
- Rake::DeprecatedObjectDSL::Commands.send(:#{name}, *args, &block)
- end
+ Rake::DeprecatedCommands.send(:#{name}, *args, &block)
+ end
private :#{name}
}, __FILE__, line
end
diff --git a/lib/rake/version.rb b/lib/rake/version.rb
index 3afad7f25a3..6c43493df9a 100644
--- a/lib/rake/version.rb
+++ b/lib/rake/version.rb
@@ -1,5 +1,5 @@
module Rake
- VERSION = '0.9.2.1'
+ VERSION = '0.9.2.2'
module Version # :nodoc: all
MAJOR, MINOR, BUILD = VERSION.split '.'
diff --git a/test/rake/helper.rb b/test/rake/helper.rb
index 636c31b266d..65443fc1117 100644
--- a/test/rake/helper.rb
+++ b/test/rake/helper.rb
@@ -282,7 +282,6 @@ end
task :prep => :clean do
mkdir_p 'src'
N.times do |n|
- puts "DBG: Touching src/foo#{n}"
touch "src/foo#{n}"
end
end
diff --git a/test/rake/test_rake_dsl.rb b/test/rake/test_rake_dsl.rb
index 294ff2bd0d1..de83b89ab41 100644
--- a/test/rake/test_rake_dsl.rb
+++ b/test/rake/test_rake_dsl.rb
@@ -56,6 +56,10 @@ class TestRakeDsl < Rake::TestCase
assert_match(/test_rake_dsl\.rb:\d+/, err)
end
+ def test_no_commands_constant
+ assert ! defined?(Commands), "should not define Commands"
+ end
+
def test_deprecated_object_dsl_with_suppressed_warnings
Rake.application.options.ignore_deprecate = true
out, err = capture_io do
diff --git a/test/rake/test_rake_functional.rb b/test/rake/test_rake_functional.rb
index 95a36e1ad92..3764709f381 100644
--- a/test/rake/test_rake_functional.rb
+++ b/test/rake/test_rake_functional.rb
@@ -436,7 +436,7 @@ class TestRakeFunctional < Rake::TestCase
def run_ruby(option_list)
puts "COMMAND: [#{RUBY} #{option_list.join ' '}]" if @verbose
- inn, out, err, wait = Open3.popen3(Gem.ruby, *option_list)
+ inn, out, err = Open3.popen3(Gem.ruby, *option_list)
inn.close
@out = out.read