summaryrefslogtreecommitdiff
path: root/vm_eval.c
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-07-17 14:51:34 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-07-17 14:51:34 +0000
commitab742d9d2ee6f56d987b17ebd1795d5922c47172 (patch)
treea9e7348e333ff50efc530235be5b064addca6968 /vm_eval.c
parent67f5f9477cac18773794ad8692f1760e3712211e (diff)
vm_eval.c: safe level 4
* vm_eval.c (rb_eval_cmd): $SAFE=4 has been deprecated. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@51284 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'vm_eval.c')
-rw-r--r--vm_eval.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/vm_eval.c b/vm_eval.c
index d389a4a..ff4abf5 100644
--- a/vm_eval.c
+++ b/vm_eval.c
@@ -1502,7 +1502,7 @@ rb_eval_cmd(VALUE cmd, VALUE arg, int level)
volatile int safe = rb_safe_level();
if (OBJ_TAINTED(cmd)) {
- level = 4;
+ level = RUBY_SAFE_LEVEL_MAX;
}
if (!RB_TYPE_P(cmd, T_STRING)) {