summaryrefslogtreecommitdiff
path: root/ext/tk
diff options
context:
space:
mode:
authornagai <nagai@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-07-19 04:43:16 +0000
committernagai <nagai@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-07-19 04:43:16 +0000
commite31da2df7ed992ed7f78fdb160186e4715837074 (patch)
tree6850821a423abb1d0de057b63150056bbc43b40d /ext/tk
parent8dd4a3c6048989a06ae0b57f929899820709715d (diff)
* ext/tk/extconf.rb: Default search_versions are set 8.5 and 8.4 only. At present, Tcl/Tk8.6 is not supported.
* ext/tk/extconf.rb: Fix typo. [ruby-core:56084] [Bug #8656] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@42059 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'ext/tk')
-rw-r--r--ext/tk/extconf.rb7
1 files changed, 5 insertions, 2 deletions
diff --git a/ext/tk/extconf.rb b/ext/tk/extconf.rb
index 40a4abd..d54fa88 100644
--- a/ext/tk/extconf.rb
+++ b/ext/tk/extconf.rb
@@ -8,7 +8,8 @@ TkLib_Config = {}
TkLib_Config['search_versions'] =
# %w[8.9 8.8 8.7 8.6 8.5 8.4 8.3 8.2 8.1 8.0 7.6 4.2]
# %w[8.7 8.6 8.5 8.4 8.3 8.2 8.1 8.0]
- %w[8.7 8.6 8.5 8.4 8.0] # to shorten search steps
+ # %w[8.7 8.6 8.5 8.4 8.0] # to shorten search steps
+ %w[8.5 8.4] # At present, Tcl/Tk8.6 is not supported.
TkLib_Config['major_nums'] = '87'
@@ -315,7 +316,7 @@ def find_macosx_framework
paths.map{|dir| dir.strip.chomp('/')}.each{|dir|
next unless File.exist?(File.join(dir, "Tcl.framework", "Headers"))
next unless File.directory?(tcldir = File.join(dir, "Tcl.framework"))
- next unless File.exist?(File.join(dir, "Tk.framework"), "Headers")
+ next unless File.exist?(File.join(dir, "Tk.framework", "Headers"))
next unless File.directory?(tkdir = File.join(dir, "Tk.framework"))
TkLib_Config["tcltk-framework"] = dir
return [tcldir, tkdir]
@@ -2046,4 +2047,6 @@ if (TkLib_Config["tcltk-framework"] ||
puts "\nFind Tcl/Tk libraries. Make tcltklib.so which is required by Ruby/Tk."
else
puts "\nCan't find proper Tcl/Tk libraries. So, can't make tcltklib.so which is required by Ruby/Tk."
+ puts "If you have Tcl/Tk libraries on your environment, you may be able to use them with configure options (see ext/tk/README.tcltklib)."
+ puts "At present, Tcl/Tk8.6 is not supported. Although you can try to use Tcl/Tk8.6 with configure options, it will not work correctly. I recommend you to use Tcl/Tk8.5 or 8.4."
end