summaryrefslogtreecommitdiff
path: root/ext/psych
diff options
context:
space:
mode:
authorDavid Rodríguez <deivid.rodriguez@riseup.net>2020-02-26 18:36:11 +0100
committerNobuyoshi Nakada <nobu@ruby-lang.org>2020-06-05 11:49:56 +0900
commit5ed58b90d188b26e5369397b48edaba287ab09fe (patch)
treee7a6de0654bbc667f3781bdf80ca5fc9678db824 /ext/psych
parentf641d78a6fcf0b96c50077503a763478d0599fe5 (diff)
[ruby/psych] Fix gem installation
Current version is not installable because the gemspec is invalid, since it includes a `.travis.yml` file that no longer exists, so `rake install` fails like this: ``` $ rake install rake aborted! WARNING: See https://guides.rubygems.org/specification-reference/ for help ERROR: While executing gem ... (Gem::InvalidSpecificationException) [".travis.yml"] are not files ``` https://github.com/ruby/psych/commit/32b18ca7ca
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/3188
Diffstat (limited to 'ext/psych')
-rw-r--r--ext/psych/psych.gemspec2
1 files changed, 1 insertions, 1 deletions
diff --git a/ext/psych/psych.gemspec b/ext/psych/psych.gemspec
index e0168af7..0990098 100644
--- a/ext/psych/psych.gemspec
+++ b/ext/psych/psych.gemspec
@@ -25,7 +25,7 @@ DESCRIPTION
# for ruby core repository. It was generated by `git ls-files -z`.split("\x0").reject { |f| f.match(%r{^(test|spec|features)/}) }
s.files = [
- ".gitignore", ".travis.yml", "Gemfile", "Mavenfile", "README.md", "Rakefile", "bin/console",
+ ".gitignore", "Gemfile", "Mavenfile", "README.md", "Rakefile", "bin/console",
"bin/setup", "ext/psych/depend", "ext/psych/extconf.rb", "ext/psych/psych.c", "ext/psych/psych.h",
"ext/psych/psych_emitter.c", "ext/psych/psych_emitter.h", "ext/psych/psych_parser.c", "ext/psych/psych_parser.h",
"ext/psych/psych_to_ruby.c", "ext/psych/psych_to_ruby.h", "ext/psych/psych_yaml_tree.c", "ext/psych/psych_yaml_tree.h",