summaryrefslogtreecommitdiff
path: root/ext/psych/lib/psych/class_loader.rb
diff options
context:
space:
mode:
authorDavid Rodríguez <deivid.rodriguez@riseup.net>2021-10-06 11:51:33 +0200
committergit <svn-admin@ruby-lang.org>2021-10-24 08:49:14 +0900
commitd04d6bbc6cf14a4e3ca292095a00c1956e63d9fb (patch)
treee01ca04aea30848179706563c4165f6f963d2b2c /ext/psych/lib/psych/class_loader.rb
parent48cd633094e5e57d1120c5d81afdbeb2290837b3 (diff)
[ruby/psych] Prefer `require_relative` for internal requires
https://github.com/ruby/psych/commit/a0f55ee85a
Diffstat (limited to 'ext/psych/lib/psych/class_loader.rb')
-rw-r--r--ext/psych/lib/psych/class_loader.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/ext/psych/lib/psych/class_loader.rb b/ext/psych/lib/psych/class_loader.rb
index 088373cd669..c2e4ea4c937 100644
--- a/ext/psych/lib/psych/class_loader.rb
+++ b/ext/psych/lib/psych/class_loader.rb
@@ -1,6 +1,6 @@
# frozen_string_literal: true
-require 'psych/omap'
-require 'psych/set'
+require_relative 'omap'
+require_relative 'set'
module Psych
class ClassLoader # :nodoc: